Admin login page is not showing



  • I have installed the QLO app on PHP 7.2.7 and MariaDB 10.2.25 and Apache 2.4.41 for testing and it seems it is working except the login page is showing nothing but a blank page. I am attaching the screenshot here:

    qlo-error.png

    Please help.

    Regards.


  • Global Moderator

    Hello @greencoder
    That's not a bug.
    To manage the back end of QloApps.

    Please go to file structure of QloApps folder
    https://prnt.sc/kuakuu

    Now find a folder whose name starts with Admin
    https://prnt.sc/kualu4

    In the URL please use the name of this folder to access the back-office.
    Ex: www.website.com/adminfoldername



  • @Faiz : I did as you said but with the same result. This is definitely a bug because at the time of installation, it did not showed any incompatibility issue. The frontend is working as shown in the demo, only the login page is inaccessible. I don't know what should be the solution. I like the frontend and the app itself is also quite small in size. But I don't know how can I enter the admin panel. 😞

    Note: If it be posted 2nd time then please ignore the 1st one because I haven't posted the same thing simultaneously, it is due to my network error.


  • Global Moderator

    @greencoder what's the URL of your website. Can you share it?



  • You can see it from the image that this is on local server. I am using WAMP.


  • Global Moderator

    Hello @greencoder
    Please turn on the dev mode then reload your front and back again.
    Then give us the screenshot of the error that is shown.
    To enable the dev mode to go to your QloApps folder --- > config --> open define.inc.php file.
    Then on line 29 change define('_PS_MODE_DEV_', false);
    to define('_PS_MODE_DEV_', true);



  • I did as you told and the admin page is same but in the frontend I got some error. As there were multiple errors and I had to take multiple screenshots to show all of them, I converted the page into a pdf. If you still need the screenshots, please let me know.

    Regards.

    qlo-error-after-editing-defines.inc.php - download pdf file



  • @Faiz Any solution friend?



  • This post is deleted!

  • Global Moderator

    @greencoder

    You can turn off the developer mode now by

    define('_PS_MODE_DEV_', false);
    

    at your QloApps folder --- > config --> open define.inc.php file.

    Regarding admin, Are you sure you are visiting the correct URL. In the screenshot, you are using http://hotelcommerce/admin in the URL.

    It may be http://localhost/hotelcommerce/admin .

    Please once check the QloApps folder (hotelcommerce/) structure and let us know the folder name which starts with admin...

    Also, can you provide us the correct frontend URL which is working fine at your end.



  • @Sumit If you use WAMP server, then the site address becomes http://hotelcommerce because the site has to be added as a virtual host. So after adding it, the address shows as http://, just like a real web address.

    I am attaching two screenshots of file structures:

    1. root folder (hotelcommerce/) file structure -

    hotelcommerce-file-structure.jpg

    1. Admin (hotelcommerce/admin) folder file structure -

    hotelcommerce-admin-folder-file-structure.jpg

    And two screenshots of the correct frontend URL which is working at my end:

    1. hotelcommerce as virtual host in WAMP server -

    hotelcommerce-on-virtualhost-WAMPServer.jpg

    1. The correct working frontend on my localhost -

    the-working-correct-path-of-hotelcommerce-on-WAMPServer.jpg

    Hope these will help you to understand the problem.

    Regards.


  • Global Moderator

    @greencoder

    After reviewing your screenshots, your back-office must open with the URL http://hotelcommerce/admin.

    It is difficult to figure out the exact reason why your back-office not working because you are working on your system's localhost server. We only can suggest solutions.

    We suggest once visit https://www.prestashop.com/forums/topic/338387-connection-was-reset-solved/ and use this solution once.

    Also, till now we have not been faced with this issue. If possible, you install QloApps on some public server and create a ticket if you face issues on that. Or install a fresh QloApps one more time and try to login back-office.



  • My back-office URL is http://hotelcommerce/admin, but it is not opening. Everything you have asked me to do, I did... in fact before installing I read the documentation and it is very easy to install, there is nothing much to do. The script itself does everything just like Joomla. I generally use Joomla for building a site, whether it is an e-commerce or a normal site but this is not the place to explain why I use Joomla. Anyway, this is the first time I tried a totally different script. Now, here is a good news. I installed QLO in my web server using a free TLD and it worked!!! I was surprised!!! Because I had no problem with WAMP when I use Joomla, but this is the first time I am facing this problem. Though I might have a faint idea why it is causing this problem. I think, there may be clash is taking place inside the code because of which QLO, is not recognizing the back-office URL as it is not a real domain. Before this instance, I installed QLO inside a folder named 'QLO', like sometimes I use 'Joomla' as the folder name when I install Joomla. In case of Joomla, I faced no problem. But when I use 'QLO' as the root folder of my site in localhost, the frontend also did not load and the URL was showing 'www.qlo.com', which was wrong. Now, this is definitely a bug and you people have to find the answer because many people use WAMP server and this type of incident will create a negative impact on them. There is another solution. In the 'System Requirement' section you can mention not to use WAMP server.


  • Global Moderator

    @greencoder

    Many users have installed QloApps on wamp server and it is working fine at their end.
    Their might be some issue on your set up because of which you are facing this problem. So we have to check the issue on your server itself. Also, we do not use 'www.qlo.com' in our script anywhere.

    I request you to once create a ticket at https://support.uvdesk.com/en/customer/create-ticket/ and explain the issue there.
    We will need some of your credentials to check the issue on your side. So we will continue discussion on this issue on your created ticket.



  • @Sumit I am really impressed about the support here. I never expected such quick response on a open source FREE script. I am really impressed. I am going to create a support ticket as per your advice and I am really eager to know what is wrong with my WAMP setup because if there are others who have installed QloApps on WAMP server without any problem then, why on earth it is giving problem on my setup?! I need to know and thanks that you people also have agreed on that. Thanks for your awesome support.

    Regards.

    Note: I forgot to mention that I have tried this solution https://www.prestashop.com/forums/topic/338387-connection-was-reset-solved/ also, but didn't work out.

    Update: I have created the ticket. The ticket number is #20466.


  • Global Moderator

    @greencoder

    We have processed your ticket and will check the issue on the ticket system itself.

    Thanks