XAMPP installation not working



  • I am a new user of this hotel commerce application. I downloaded the zip file extracted it to my htdocs folder under xampp and when i run the application I get the following error in php log.

    [05-May-2020 02:41:16 Europe/Berlin] PHP Fatal error:  Uncaught Error: Class 'Tools' not found in /Applications/XAMPP/xamppfiles/htdocs/hotelcommerce/classes/PrestaShopAutoload.php:168
    Stack trace:
    #0 /Applications/XAMPP/xamppfiles/htdocs/hotelcommerce/classes/PrestaShopAutoload.php(68): PrestaShopAutoload->generateIndex()
    #1 /Applications/XAMPP/xamppfiles/htdocs/hotelcommerce/classes/PrestaShopAutoload.php(80): PrestaShopAutoload->__construct()
    #2 /Applications/XAMPP/xamppfiles/htdocs/hotelcommerce/config/autoload.php(31): PrestaShopAutoload::getInstance()
    #3 /Applications/XAMPP/xamppfiles/htdocs/hotelcommerce/install/init.php(50): require_once('/Applications/X...')
    #4 /Applications/XAMPP/xamppfiles/htdocs/hotelcommerce/install/index.php(27): require_once('/Applications/X...')
    #5 {main}
      thrown in /Applications/XAMPP/xamppfiles/htdocs/hotelcommerce/classes/PrestaShopAutoload.php on line 168
    

    Because its a package i have not tried anything as I don't want to corrupt it.


  • Global Moderator

    hello @ramkithepower

    Please provide us the php version that you are using.

    Does this issue causes break in installation, then please provide us the screenshot of the issue.

    It looks like the issue is with file access permissions. Please set the folders to "755" and the file's permission to "666" and try the installation again.



  • @shreesh Thanks this solved the problem. I had to separately give access to files though i already gave for the folders.