Qloapps keep redirecting https to http



  • I'm trying to setup ssl and domain for my website.
    For domain, I haved change document root of xampp from "xampp_folder" to "xampp_folder/qloapp_folder" so my domain will have type of domain.com instead of domain.com/qloapp_folder.
    And I change setting in Qloapps as below
    a0f8917e-b781-4dba-9f15-c191d89ca0f9-image.png

    By now, the domain part working just fine. I can access my website by enter http://hotel.thingnet.vn/vn/

    Then i try to setup ssl and make all http request redirect to https.
    I follow this guide http://robsnotebook.com/xampp-ssl-encrypt-passwords
    But on the rewrite part I make it short by just write

    
        RewriteEngine On
        RewriteCond %{HTTPS} !=on
        RewriteRule (.*) https://%{SERVER_NAME}/$1 [L,R=301]
    
    

    in httpd-xampp.conf instead of his rule for specific folder.
    But somehow i can't make it work, even if I follow his rule.
    I can access to https://hotel.thingnet.vn/phpmyadmin/, it does have a valid certificate, but when I write http://hotel.thingnet.vn/phpmyadmin/, it does not redirect to https.
    For my website, when I type https://hotel.thingnet.vn/vn/, it keep redirecting to http://hotel.thingnet.vn/vn/.
    I wonder if my setting is wrong at some point? Did my rule is overwrite by your rule in .htaccess file? And if I change .htaccess file in Qloapps folder, if I make change after tag #end, then all my customize is still being keeped even if it getting regenerate when i press save on SEO & URL setting, right?



  • nvm, I just realize that I have to turn on Enable SSL on preference/generals.
    But I still wonder about customer .htaccess file.


  • Global Moderator

    @tien95

    To enable redirecting your website to https you only need to enable SSL in your shop.
    QloApps automatically changes the .htaccess to allow redirection to https, so you need not required to add rewrite rules in your server config file.

    To enable SSL please follow the following steps.
    At the back end, GoTo Preferences Tab and Select General in the drop-down menu. https://prnt.sc/l41djt
    Now, click Yes for Enable SSL and click on Save. https://prnt.sc/mq81cd
    Now click Yes to Enable SSL on all Pages. Click Save and reload the page, it should work. https://prnt.sc/mq82h0

    QloApps only regenerates the .htaccess file in between #start and #end tags and will keep the changes done after the #end tag, when you change SEO & URL setting.


Log in to reply