@leentje96

Issue - Property Category->link_rewrite is empty.

It looks like you are using accented (non-latin) characters in the city, state names while creating Hotel.
So for this, you have to enable the "Accented URL" option from Preferences -> SEO & URLs tab https://prnt.sc/rygvjh.

After this save the hotel again and try to search again.